Create debian usb bootable USB stick under macOS.

  • By :
  • Category : Linux

To create debian bootable disk you can use tools already available in macOS.
We are going to use:

  • Disk Utility
  • diskutil
  • dd (/bin/dd)
  1. With “Disk Utility” you can format usb memory, delete all partition etc. Select the external disk and format as FAT
  2. Convert iso image to dmg, using the command:
    hdiutil convert debian-11.6.0-amd64-DVD-1.iso -format UDRW -o debian-11.6.0-amd64-DVD-1.dmg
  3. Check external disk name
    diskutil list
  4. Umount the disk
    diskutil unmountDisk /dev/disk4 // assuming /dev/disk4 is your external disk
  5. Write the image to the external disk:
    sudo dd if=debian-11.6.0-amd64-DVD-1.dmg of=/dev/disk4 bs=1m

If you need to remove partition from your external drive and “Disk Utility” is no able to do that, you can use the following example: diskutil eraseDisk JHFS+ UntitledUFS disk4.
That would destroy everything what is on the drive and set the JHFS+ filesystem.

Note: there are other applications with nice GUI that can do the whole steps all together – but why not to use something that is already and ready to use.

No Comments

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Free(BSD)
Search for duplicated files

This will be short (but hopefully I will find more time to show entire process to search duplicated files together with some examples). In case you are searching for duplicated files I can recommend two software which actually rocks in openSource world

Linux
2
“Gaming laptop”, steam link and rustdesk.

Not really related to this article, but just wanted to describe the situation.  Most of the time I am working on Linux or Mac. Not a big deal, but last year we bought my daughter a kind of gaming laptop. I am saying kind of, because IMHO there is no …

Azure
NFS issue, cannot be mounted or is not visible

The same kind of issue I have encountered numerous times while working across different environments and with various customers. The problem with NFS mounts connected from remote locations is so common. This issue extends beyond communication solely over WAN and also include connections between datacenters (DC) where we lack control …